Page Index Toggle Pages: 1 2 3 [4]  Send TopicPrint
Very Hot Topic (More than 25 Replies) Dark Shadows Reissued for YaBB 2.4 (Read 10256 times)
MasterKarman
Junior Member
**
Offline


YaBB 2.5.2

Posts: 90
Location: Karmanville
Joined: Feb 14th, 2009
Gender: Male
Re: Dark Shadows Reissued for YaBB 2.4
Reply #45 - Mar 12th, 2011 at 10:05am
Print Post  
wow, thank you.
This is exactly the type of template I've been wanting now that I have some time to redo my forum.
kudos
  

Now using YaBB 2.5.2 with 40+mods
"The world is a dangerous place to live. Not because of the evil in it, but because of the people who don't do anything about it."


Back to top
IP Logged
 
Rob Sherratt
New Member
*
Offline


I Love YaBB 2!

Posts: 6
Joined: Jun 10th, 2011
Re: Dark Shadows Reissued for YaBB 2.4
Reply #46 - Jun 10th, 2011 at 11:42am
Print Post  
Very nice template, thanks.  Is there a need for any changes to the Dark Shadows template if I update my forum software from YaBB 2.4 to 2.5 ?
  
Back to top
 
IP Logged
 
Rob Sherratt
New Member
*
Offline


I Love YaBB 2!

Posts: 6
Joined: Jun 10th, 2011
Re: Dark Shadows Reissued for YaBB 2.4
Reply #47 - Jun 10th, 2011 at 11:48am
Print Post  
Sorry - I just saw your earlier answer - there would be some changes needed to the template for compatibility with YaBB 2.5, so I'll stick with YaBB 2.4 for now, thanks.
  
Back to top
 
IP Logged
 
Derek Barnstorm
God Member
*****
Offline



Posts: 1146
Location: Warwickshire
Joined: Mar 23rd, 2008
Gender: Male
Re: Dark Shadows Reissued for YaBB 2.4
Reply #48 - Jun 10th, 2011 at 12:36pm
Print Post  
Hi Rob,

The changes would actually be very minimal. Off the top of my head you would just need to make these three edits:

In DarkShadows.html find:

Code
Select All
{yabb style} 


And add after:

Code
Select All
{yabb syntax_js} 


Then find:

Code
Select All
	<div style="float: left;">{yabb navback}</div> 


And add the highlighted:

Code
Select All
	<div class="nav" style="float: left;">{yabb navback}</div> 


Then in DarkShadows.css find:

Code
Select All
.nav, a.nav {
        font-weight: bold;
        font-size: 10px;
        color : #ffffff;
        text-decoration: none;
}
a.nav:hover {
        color: #aaaaaa;
        text-decoration: overline underline;
} 


And replace with:

Code
Select All
.nav {
        font-weight: bold;
        font-size: 10px;
        color : #ffffff;
        text-decoration: none;
}
.nav a {
        font-weight: bold;
        font-size: 10px;
        color : #ffffff;
        text-decoration: none;
}
.nav a:hover {
        color: #aaaaaa;
        text-decoration: overline underline;
} 


There's possibly something that I've forgotten, but I'm pretty sure they're the main things you need to worry about.
« Last Edit: Jun 12th, 2011 at 12:16pm by Derek Barnstorm »  
Back to top
 
IP Logged
 
Rob Sherratt
New Member
*
Offline


I Love YaBB 2!

Posts: 6
Joined: Jun 10th, 2011
Re: Dark Shadows Reissued for YaBB 2.4
Reply #49 - Jun 10th, 2011 at 2:23pm
Print Post  
Hi Derek,

Thanks very much for such a rapid and knowledgeable response.  You are extremely helpful.  I will go ahead with the forum upgrade and these changes.

Best regards,
Rob Sherratt
  
Back to top
 
IP Logged
 
Rob Sherratt
New Member
*
Offline


I Love YaBB 2!

Posts: 6
Joined: Jun 10th, 2011
Re: Dark Shadows Reissued for YaBB 2.4
Reply #50 - Jun 10th, 2011 at 2:42pm
Print Post  
Hi Derek,

A follow-on question, please?  The first 18 lines in the file DarkShadows.html are now:

Code
Select All
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
  <!-- YaBB 2.5 AE $Revision: 1.20 $ -->
  <title>{yabb title}</title>
  <meta http-equiv="Content-Type" content="text/html; charset={yabb charset}" />
  {yabb style}
  {yabb syntax_js}
  <script language="JavaScript1.2" type="text/javascript" src="{yabb html_root}/YaBB.js"></script>
  <script language="JavaScript1.2" type="text/javascript">
    <!--
    //force no cache
    if ((navigator.appVersion.substring(0,1) == "5" && navigator.userAgent.indexOf('Gecko') != -1) || navigator.userAgent.search(/Opera/) != -1)
      {document.write('<meta http-equiv="pragma" CONTENT="no-cache" />');}
    {yabb javascript}
    // -->
  </script>
</head> 


That's 100% the same as the YaBB 2.5 default.html header.  I'm particularly puzzled by {yabb javascript} being disabled - why is the use of javascript associated with "force no cache"?

Thanks,
Rob
  
Back to top
 
IP Logged
 
Derek Barnstorm
God Member
*****
Offline



Posts: 1146
Location: Warwickshire
Joined: Mar 23rd, 2008
Gender: Male
Re: Dark Shadows Reissued for YaBB 2.4
Reply #51 - Jun 10th, 2011 at 3:04pm
Print Post  
Hi again,

That's absolutely fine as it is. The JS tag isn't actually associated with the no-cache meta tag - If you take a closer look at the code you'll see that it is not part of the if statement:

Code
Select All
<script language="JavaScript1.2" type="text/javascript">
<!--
//force no cache
if ((navigator.appVersion.substring(0,1) == "5" && navigator.userAgent.indexOf('Gecko') != -1) || navigator.userAgent.search(/Opera/) != -1) {
    document.write('<meta http-equiv="pragma" CONTENT="no-cache" />');
}
{yabb javascript}
// -->
</script> 


  
Back to top
 
IP Logged
 
Rob Sherratt
New Member
*
Offline


I Love YaBB 2!

Posts: 6
Joined: Jun 10th, 2011
Re: Dark Shadows Reissued for YaBB 2.4
Reply #52 - Jun 10th, 2011 at 3:49pm
Print Post  
That's true, but why is JS unconditionally disabled?
  
Back to top
 
IP Logged
 
Derek Barnstorm
God Member
*****
Offline



Posts: 1146
Location: Warwickshire
Joined: Mar 23rd, 2008
Gender: Male
Re: Dark Shadows Reissued for YaBB 2.4
Reply #53 - Jun 10th, 2011 at 3:58pm
Print Post  
Sorry, I'm not too sure what you mean? JS isn't ever disabled in YaBB.

If you ignore that if statement, then the code simply looks like this:

Code
Select All
<script language="JavaScript1.2" type="text/javascript">
<!--
{yabb javascript}
// -->
</script> 

  
Back to top
 
IP Logged
 
Rob Sherratt
New Member
*
Offline


I Love YaBB 2!

Posts: 6
Joined: Jun 10th, 2011
Re: Dark Shadows Reissued for YaBB 2.4
Reply #54 - Jun 10th, 2011 at 6:47pm
Print Post  
Hi Derek,

The <!--       --> construct comments out the {yabb javascript} statement so that particular statement is at present inactive.  For it to become active the <!--       --> comment delimiters would have to be removed.  I don't understand why {yabb javascript} is at present commented out in the template.  Nor do I understand what the {yabb javascript} statement was originally designed to achieve. Anyway it's not really relevant now because ...

... thanks to you the Corcyra user forum is now updated to YaBB 2.5 and is running the modified DarkShadows template.  

I also copied across the 'default' template files from the 2.5 full distribution, so users can switch their accounts to use the default YaBB 2.5 Anniversary Edition template if they prefer to do so. The "upgrade" process left the 'default' template unusable otherwise.

Thanks,
Rob
  
Back to top
 
IP Logged
 
Derek Barnstorm
God Member
*****
Offline



Posts: 1146
Location: Warwickshire
Joined: Mar 23rd, 2008
Gender: Male
Re: Dark Shadows Reissued for YaBB 2.4
Reply #55 - Jun 10th, 2011 at 7:05pm
Print Post  
Ah, the HTML comments. They're used in JavaScript to tell very old browsers or browsers which don't support JavaScript to ignore it. Some coders do leave them out now, but most still consider it good practice to keep them in. So it won't make it inactive unless it's a browser which doesn't support JS.

The {yabb javascript} tag brings in JavaScript from the actual code. For example:

Code
Select All
    $yyjavascript .= qq~

    function txtInFields(thefield, defaulttxt) {
	  if (thefield.value == defaulttxt) thefield.value = "";
	  else { if (thefield.value == "") thefield.value = defaulttxt; }
    }
    ~; 


If you view the page source then you'll see the actual JS and not the YaBB tag. Hope that makes sense to you.
  
Back to top
 
IP Logged
 
L_ith
Junior Member
**
Offline


A LoSt Dream~

Posts: 83
Location: Im lost~
Joined: Jul 11th, 2006
Gender: Male
Re: Dark Shadows Reissued for YaBB 2.4
Reply #56 - Jun 12th, 2011 at 3:31pm
Print Post  
Nice,

will you re-make this again for 3.0 ? or

no chance in hell?  Huh
  
Back to top
 
IP Logged
 
Derek Barnstorm
God Member
*****
Offline



Posts: 1146
Location: Warwickshire
Joined: Mar 23rd, 2008
Gender: Male
Re: Dark Shadows Reissued for YaBB 2.4
Reply #57 - Jun 12th, 2011 at 4:19pm
Print Post  
I guess that depends on whether YaBB3 ever gets released or not. As the old saying goes, "Only time will tell". Wink Smiley
  
Back to top
 
IP Logged
 
L_ith
Junior Member
**
Offline


A LoSt Dream~

Posts: 83
Location: Im lost~
Joined: Jul 11th, 2006
Gender: Male
Re: Dark Shadows Reissued for YaBB 2.4
Reply #58 - Jun 12th, 2011 at 8:16pm
Print Post  
Derek Barnstorm wrote on Jun 12th, 2011 at 4:19pm:
I guess that depends on whether YaBB3 ever gets released or not. As the old saying goes, "Only time will tell". Wink Smiley


It will be released, so im not worried you know what to do when Y3 is released !
Wink

Cant wait i have faith in you hehe  Cool
  
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1 2 3 [4] 
Send TopicPrint