Page Index Toggle Pages: 1 [2] 3 4  Send TopicPrint
Very Hot Topic (More than 25 Replies) CSS Buttons 4 YaBB 2.4 (and 2.3.1) (beta 0.1.5) (Read 2470 times)
Carsten
God Member
*****
Offline


...to much YaMS

Posts: 3281
Location: Langå
Joined: Aug 2nd, 2002
Gender: Male
Re: CSS Buttons 4 YaBB 2.4 (beta 0.1)
Reply #15 - Apr 25th, 2009 at 9:29pm
Print Post  
Beta 0.1.1 - added a few missing buttons. All changes are in "/Variables/Menu.def". New zip attached to first post.
  

If you knock your head against a brick wall and hear a hollow sound, it's not necessarily coming from the wall.
Back to top
 
IP Logged
 
Derek Bullock
Full Member
***
Offline


I love Camp Oven Cooking

Posts: 184
Location: Brisbane
Joined: Nov 9th, 2007
Gender: Male
Re: CSS Buttons 4 YaBB 2.4 (beta 0.1)
Reply #16 - Apr 26th, 2009 at 3:07am
Print Post  
@ Carsten

Do you have a solution for my issue in reply #12.

Thank you
  

Back to top
WWW  
IP Logged
 
Cable
Junior Member
**
Offline


I love YaBB 1G - SP1.2!

Posts: 97
Joined: Sep 28th, 2007
Re: CSS Buttons 4 YaBB 2.4 (beta 0.1)
Reply #17 - Apr 26th, 2009 at 3:50am
Print Post  
I had the same problem.  I'm using the updated zip file.

Looking at the source text of my Board Index display, it shows this for an example button code:
Code
Select All
<span class="buttonimage" style="height: 20px; border: 0px; margin: 0px; background-image: url(http://www.mydomain.com/tf/yabbfiles/ModImages/expand.gif); background-repeat: no-repeat; vertical-align: top; text-decoration: none; font-size: 18px; display: inline-block;"> 



There were no ModImages files in the Mod zip.  Mod itself says nothing about them.

Did you forget something, Carsten?  Lips Sealed

  
Back to top
 
IP Logged
 
Cable
Junior Member
**
Offline


I love YaBB 1G - SP1.2!

Posts: 97
Joined: Sep 28th, 2007
Re: CSS Buttons 4 YaBB 2.4 (beta 0.1)
Reply #18 - Apr 26th, 2009 at 4:16am
Print Post  
Found another possible issue, may or may not be related.  The issue is this; if you have more than one template on the forum, it appears you may have to modify ALL your template/CSS files on the forum or lose part of the buttons, but I can't be sure until I get the ModImages graphics.

I installed the mod on my 2.4 test forum.  I have 12 templates on that forum.  I altered the CSS file for every template per the CSS add-in instructions included in the zip.  I uploaded the yabbfiles/Templates/Forum/default graphics files to each template's graphics folder.

I made new xxx_left.png and xxx_right.png files using my Metallic Gold, Chrome, and Sandstone gradient/texture files.  I uploaded all 6 graphic files to yabbfiles/Buttons folder.

See the attached picture below.  View 1 shows the results in the Gold template.  Okay, as described above, probably missing some icon images from the ModImages folder, but the background came out nice.

But then I switched to the Sandstonee template and before doing anything with it I noticed the button background colors were the standard colors but the icons were missing (view 2)

View 3 shows the Sandstone background added.

  

cssbuttons_no_icons.jpg ( 26 KB | Downloads )
cssbuttons_no_icons.jpg
Back to top
 
IP Logged
 
Carsten
God Member
*****
Offline


...to much YaMS

Posts: 3281
Location: Langå
Joined: Aug 2nd, 2002
Gender: Male
Re: CSS Buttons 4 YaBB 2.4 (beta 0.1.2)
Reply #19 - Apr 26th, 2009 at 6:39am
Print Post  
@ Derek and Cable - Attached new beta 0.1.2 to first post to fix (hopefully) the missing icons issue. All changes are in "Sources/Menu.pl".

My problem is that everything is working nicely on my test boards.
  

If you knock your head against a brick wall and hear a hollow sound, it's not necessarily coming from the wall.
Back to top
 
IP Logged
 
Derek Bullock
Full Member
***
Offline


I love Camp Oven Cooking

Posts: 184
Location: Brisbane
Joined: Nov 9th, 2007
Gender: Male
Re: CSS Buttons 4 YaBB 2.4 (beta 0.1.2)
Reply #20 - Apr 26th, 2009 at 6:42am
Print Post  
Many thanks.  Now working.

Derek
  

Back to top
WWW  
IP Logged
 
Carsten
God Member
*****
Offline


...to much YaMS

Posts: 3281
Location: Langå
Joined: Aug 2nd, 2002
Gender: Male
Re: CSS Buttons 4 YaBB 2.4 (beta 0.1.2)
Reply #21 - Apr 26th, 2009 at 6:52am
Print Post  
Derek Bullock wrote on Apr 26th, 2009 at 6:42am:
Many thanks.Now working.

What a relief Smiley
You are welcome Derek. Thanks for testing and reporting.
  

If you knock your head against a brick wall and hear a hollow sound, it's not necessarily coming from the wall.
Back to top
 
IP Logged
 
Carsten
God Member
*****
Offline


...to much YaMS

Posts: 3281
Location: Langå
Joined: Aug 2nd, 2002
Gender: Male
Re: CSS Buttons 4 YaBB 2.4 (beta 0.1.2)
Reply #22 - Apr 26th, 2009 at 6:58am
Print Post  
Cable wrote on Apr 26th, 2009 at 4:16am:
I uploaded the yabbfiles/Templates/Forum/default graphics files to each template's graphics folder.

No need for that - if a icon is not found in the custom template graphics folder the script will look for it in the default folder.

Cable wrote on Apr 26th, 2009 at 4:16am:
But then I switched to the Sandstonee template and before doing anything with it I noticed the button background colors were the standard colors but the icons were missing (view 2)

Maybe a browser cache problem - did you try a reload? Some browsers are real cache buggers when it comes to css.
  

If you knock your head against a brick wall and hear a hollow sound, it's not necessarily coming from the wall.
Back to top
 
IP Logged
 
Cable
Junior Member
**
Offline


I love YaBB 1G - SP1.2!

Posts: 97
Joined: Sep 28th, 2007
Re: CSS Buttons 4 YaBB 2.4 (beta 0.1.2)
Reply #23 - Apr 26th, 2009 at 4:17pm
Print Post  
Carsten that last fix to the mod did it... all now working perfectly.

The problem I was seeing in the Sandstone template before assigning the new button color was simply due to the mod making all buttons on all templates the same way, so it didn't matter if I'd changed the color or not.  But not to worry, I checked with other templates I've not yet chosen a color for and they work just fine.

So your fix addressed both issues I was having.  Everything works great now!  Thanks.

Quote:
No need for that - if a icon is not found in the custom template graphics folder the script will look for it in the default folder.


Aha, well that makes it even easier.  New template only needs two images in the Buttons folder and the CSS add-in text.  Easy.

Edited:
Update: I just revised all my YaBB 2.4 templates released so far to include support for this Mod.  I think this Mod is so great I'll be including a set of graphics and the CSS add-in in all my future template releases.  I've made about 20 sets of custom-shaded Main Forum buttons now (manually, 1 at a time), taking me about 4 hours to do a complete set.  Now it takes me about 30 seconds to make two graphic files.  So you can see why I like this mod so much!  This is a masterpiece, Carsten.  A masterpiece!

« Last Edit: Apr 27th, 2009 at 1:09am by Cable »  
Back to top
 
IP Logged
 
Carsten
God Member
*****
Offline


...to much YaMS

Posts: 3281
Location: Langå
Joined: Aug 2nd, 2002
Gender: Male
Re: CSS Buttons 4 YaBB 2.4 (beta 0.1.2)
Reply #24 - Apr 27th, 2009 at 7:05pm
Print Post  
Well that's great Tom - thanks for the nice words  Smiley
  

If you knock your head against a brick wall and hear a hollow sound, it's not necessarily coming from the wall.
Back to top
 
IP Logged
 
Cable
Junior Member
**
Offline


I love YaBB 1G - SP1.2!

Posts: 97
Joined: Sep 28th, 2007
Re: CSS Buttons 4 YaBB 2.4 (beta 0.1.2)
Reply #25 - Apr 29th, 2009 at 6:42am
Print Post  
Found a couple things odd tonight.  Whenever you use the WYSIWYG Style Sheet editor, anytime you click anything outside the visual view window it resets the window to the top.  So, for example, if you want to set colors for your Input button, you scroll down to view the button... but as soon as you click the radio button for Font, background, etc. the view snaps back up to the top.  You can only make the change then rescroll to view it. That's one odd thing.

The other is the WYSIWYG editor will not alter the settings for the Text Field (Input).  The font change will show itself changed, but the display (and the actual css entry) do not change, as shown in attached pic.

The Select Box properties do not change either.   Not too long before release of 2.4 the problem that always existed with Text Field Input and Button Input updating at the same time was fixed, so I know this worked in the stock 2.4.  The only mod I have on this forum is the CSS Buttons mod.

So, Carsten, could you please have a look and see if you are able to duplicate this behavior and if maybe something in the code needs a tweak?  Thanks.
  

oops1.jpg ( 37 KB | Downloads )
oops1.jpg
Back to top
 
IP Logged
 
Carsten
God Member
*****
Offline


...to much YaMS

Posts: 3281
Location: Langå
Joined: Aug 2nd, 2002
Gender: Male
Re: CSS Buttons 4 YaBB 2.4 (beta 0.1.2)
Reply #26 - Apr 29th, 2009 at 10:45pm
Print Post  
I'd say the odd thing is this style selector in the .css files:

input, .button {

Guess it should just have been:

.button {

But now that it's there in the distribution we better learn to live with it  Tongue

I've removed the step in the .mod file that took care of all the input selectors. This have made the mod a little more dependent of the format of the css file - but everything has a price.

Also changed the way the css button settings updates the preview window to avoid unwanted updating.

New zip attached to first post.
  

If you knock your head against a brick wall and hear a hollow sound, it's not necessarily coming from the wall.
Back to top
 
IP Logged
 
Cable
Junior Member
**
Offline


I love YaBB 1G - SP1.2!

Posts: 97
Joined: Sep 28th, 2007
Re: CSS Buttons 4 YaBB 2.4 (beta 0.1.3)
Reply #27 - Apr 30th, 2009 at 4:14am
Print Post  
That is a bizarre way to have the button selector in the css, but it worked when button was added to ManageTemplates.pl (before only input was in there) in this bug fix.  That's why I suspected maybe something in the mod altered how it worked in some way.

I won't get an opportunity to test the new zip until this seekend, but I am confident it will work just fine.
  
Back to top
 
IP Logged
 
Cable
Junior Member
**
Offline


I love YaBB 1G - SP1.2!

Posts: 97
Joined: Sep 28th, 2007
Re: CSS Buttons 4 YaBB 2.4 (beta 0.1.3)
Reply #28 - May 3rd, 2009 at 5:14pm
Print Post  
Tested the update fix today and it works perfectly now. 

Thanks, Carsten!

1 question... is your scrollfix mod incorporated in this mod?  I'm not getting any scrolling-to-top in the WYSIWYG editor when I go back to the style sheet selections menu with just this mod installed.

  
Back to top
 
IP Logged
 
Carsten
God Member
*****
Offline


...to much YaMS

Posts: 3281
Location: Langå
Joined: Aug 2nd, 2002
Gender: Male
Re: CSS Buttons 4 YaBB 2.4 (beta 0.1.3)
Reply #29 - May 3rd, 2009 at 9:01pm
Print Post  
Cable wrote on May 3rd, 2009 at 5:14pm:
1 question... is your scrollfix mod incorporated in this mod?I'm not getting any scrolling-to-top in the WYSIWYG editor when I go back to the style sheet selections menu with just this mod installed.

Nope - but i forgot to mention that the scroll to top problem only exist in IE and Opera.
  

If you knock your head against a brick wall and hear a hollow sound, it's not necessarily coming from the wall.
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1 [2] 3 4 
Send TopicPrint