Page Index Toggle Pages: [1] 2 3 4 Send TopicPrint
Very Hot Topic (More than 25 Replies) Audio Player in Profile V1.4 for YaBB 2.3/2.3.1 (Read 1968 times)
Derek Barnstorm
God Member
*****
Offline



Posts: 1146
Location: Warwickshire
Joined: Mar 23rd, 2008
Gender: Male
Audio Player in Profile V1.4 for YaBB 2.3/2.3.1
Oct 16th, 2008 at 7:48pm
Print Post  
Audio Player in Profile V 1.4


Description:
This mod uses JW Player to allow users to add a link to an Mp3 in User CP and play it back from their profile.

Screenshots:
User CP:


Profile:


Admin Center - Forum Settings - Members - Profile


Zip package:
Audio_Player_in_Profile_V_1_4.mod
cgi-bin/yabb2/Languages/English/Audio.lng
cgi-bin/yabb2/Languages/German/Audio.lng
cgi-bin/yabb2/Languages/German_Du/Audio.lng
html_root/yabbfiles/swfobject.js

Installation:
1) Modify YaBB files using BoardMod or manually.
2) Load modified files to your server.

Files to edit:
Admin/Modlist.pl
Admin/NewSettings.pl
Admin/Settings_Main.pl
Sources/Profile.pl
Sources/System.pl

History:
1.0 - Original Version - 15th July 2008
1.1 - Added Enable/Disable in Admin Center - 23rd July 2008
1.2 - Fixed small bug - If disabled in Admin Center after users had linked to Mp3 the player was still showing - 28th July 2008
1.3 - Removed code from MyCenter.pl. Added German and German_Du language - 16th August 2008
1.4 - Updated for YaBB 2.3 - 16th October 2008
« Last Edit: Jan 27th, 2009 at 3:56am by Derek Barnstorm »  
Back to top
 
IP Logged
 
discave
New Member
*
Offline


I love YaBB 1G - SP1.2!

Posts: 3
Joined: Oct 16th, 2008
Re: Audio Player in Profile V1.4 for YaBB 2.3
Reply #1 - Oct 17th, 2008 at 1:38am
Print Post  
Great stuff m8, it work's perfect.
One thing: Can it play automatic?
  
Back to top
 
IP Logged
 
Derek Barnstorm
God Member
*****
Offline



Posts: 1146
Location: Warwickshire
Joined: Mar 23rd, 2008
Gender: Male
Re: Audio Player in Profile V1.4 for YaBB 2.3
Reply #2 - Oct 17th, 2008 at 2:11am
Print Post  
Open Sources/Profile.pl and find this line...

Code
Select All
        s1.addParam('flashvars','file=${$uid.$user}{'audio'}&'); 



Replace it with this...

Code
Select All
s1.addParam('flashvars','file=${$uid.$user}{'audio'}&autostart=true'); 



I'll see if I can add an option for it in the future...
  
Back to top
 
IP Logged
 
discave
New Member
*
Offline


I love YaBB 1G - SP1.2!

Posts: 3
Joined: Oct 16th, 2008
Re: Audio Player in Profile V1.4 for YaBB 2.3
Reply #3 - Oct 17th, 2008 at 5:58am
Print Post  
thx m8, it work perfect in my board
  
Back to top
 
IP Logged
 
Derek Barnstorm
God Member
*****
Offline



Posts: 1146
Location: Warwickshire
Joined: Mar 23rd, 2008
Gender: Male
Re: Audio Player in Profile V1.4 for YaBB 2.3
Reply #4 - Oct 17th, 2008 at 2:05pm
Print Post  
No problem...

I'll add add an option for it in Admin center next time.
  
Back to top
 
IP Logged
 
ProgMaster
New Member
*
Offline



Posts: 36
Location: Offshore
Joined: Mar 2nd, 2007
Gender: Male
Re: Audio Player in Profile V1.4 for YaBB 2.3
Reply #5 - Oct 18th, 2008 at 6:01pm
Print Post  
An excellent looking mod !! 8)

Does this only work with MP3 files or are other (audio) files supported ?

Thanks !

D
  
Back to top
WWW  
IP Logged
 
Derek Barnstorm
God Member
*****
Offline



Posts: 1146
Location: Warwickshire
Joined: Mar 23rd, 2008
Gender: Male
Re: Audio Player in Profile V1.4 for YaBB 2.3
Reply #6 - Oct 18th, 2008 at 11:55pm
Print Post  
Just MP3s I'm afraid...
  
Back to top
 
IP Logged
 
ProgMaster
New Member
*
Offline



Posts: 36
Location: Offshore
Joined: Mar 2nd, 2007
Gender: Male
Re: Audio Player in Profile V1.4 for YaBB 2.3
Reply #7 - Oct 24th, 2008 at 6:19pm
Print Post  
Just thought that I'd ask, Derek.

Many thanks - looks like an excellent mod. 8)
  
Back to top
WWW  
IP Logged
 
gman
Junior Member
**
Offline


The Mod Mangler <HeLp_mE>

Posts: 79
Location: Altered States
Joined: Aug 24th, 2007
Gender: Male
Re: Audio Player in Profile V1.4 for YaBB 2.3
Reply #8 - Oct 26th, 2008 at 5:32pm
Print Post  
I installed this mod and it rocks

Nice job!

Thank you its appreciated.

8)
  

Unfortunately, prior to my birth, Missouri had not outlawed inbreeding.
Back to top
WWWYIM  
IP Logged
 
Derek Barnstorm
God Member
*****
Offline



Posts: 1146
Location: Warwickshire
Joined: Mar 23rd, 2008
Gender: Male
Re: Audio Player in Profile V1.4 for YaBB 2.3
Reply #9 - Oct 26th, 2008 at 10:39pm
Print Post  
No problem... Glad you like it!
  
Back to top
 
IP Logged
 
Outumuro
God Member
*****
Offline


Publisher - YaBB Toolbar

Posts: 569
Location: Los Angeles
Joined: Apr 14th, 2004
Gender: Male
Re: Audio Player in Profile V1.4 for YaBB 2.3
Reply #10 - Oct 27th, 2008 at 7:56am
Print Post  
  


Back to top
WWW  
IP Logged
 
Imp_In_Training
God Member
*****
Offline


Don't follow me, I'm lost
too!

Posts: 608
Location: Aberdeen
Joined: Jun 17th, 2004
Gender: Male
Re: Audio Player in Profile V1.4 for YaBB 2.3
Reply #11 - Dec 20th, 2008 at 3:51am
Print Post  
I tried to load this on my beta site and it just didn't work. Not sure why.  I'll give it another shot tomorrow, maybe I just transferred something wrong.  The audio player would just sit there.  Does it take a long time to load?  Maybe I wasn't patient enough.

As for playing something that isn't mp3... there are translation programs out there to change your other audio files into mp3... just food for thought.  I did that with my test file... not that it mattered... but at least I know the test file was working right.
  
Back to top
WWW  
IP Logged
 
Imp_In_Training
God Member
*****
Offline


Don't follow me, I'm lost
too!

Posts: 608
Location: Aberdeen
Joined: Jun 17th, 2004
Gender: Male
Re: Audio Player in Profile V1.4 for YaBB 2.3
Reply #12 - Dec 20th, 2008 at 6:02pm
Print Post  
Still having the same problem.  Funny thing is, my Profile.pl file is much larger on my computer than on the server.  I've uploaded in ASCII.

In fact, it is only the same size when I upload in BINARY... but I know that's not right. 

Not sure what to think... maybe my Profile.pl is corrupted somehow, but I took a copy of Profile.pl from a fresh unzip of YaBB 2.3 and it did the same thing.

I've asked my co-GM to test this on my site to see if maybe it is just something related with my browser.
  
Back to top
WWW  
IP Logged
 
Imp_In_Training
God Member
*****
Offline


Don't follow me, I'm lost
too!

Posts: 608
Location: Aberdeen
Joined: Jun 17th, 2004
Gender: Male
Re: Audio Player in Profile V1.4 for YaBB 2.3
Reply #13 - Dec 20th, 2008 at 6:10pm
Print Post  
My Co-GM is having the same problem.  The audio file just doesn't play.
  
Back to top
WWW  
IP Logged
 
Derek Barnstorm
God Member
*****
Offline



Posts: 1146
Location: Warwickshire
Joined: Mar 23rd, 2008
Gender: Male
Re: Audio Player in Profile V1.4 for YaBB 2.3
Reply #14 - Dec 20th, 2008 at 7:52pm
Print Post  
Yeah, I've just checked this out on your test forum... The browser can't find the swfobject.js ... It should be looking for http://beta.darkandmoodyforums.com/public_html/yabbfiles/swfobject.js but with yours it's looking for something like http://beta.darkandmoodyforums.com/public_html/yabbfiles/swfobject.js?123 ... For some reason it's got a question mark followed by a few numbers at the end... I'm not too sure why it's doing it though I'm afraid, I suppose it could be a corrupt Profile.pl, but really not sure...
  
Back to top
 
IP Logged
 
Page Index Toggle Pages: [1] 2 3 4
Send TopicPrint