Page Index Toggle Pages: 1 2 [3]  Send TopicPrint
Very Hot Topic (More than 25 Replies) Spell Checker V1.1a for YaBB 2.2.2 (Read 18694 times)
ccarr
Ex Member


Re: Spell Checker V1.1a for YaBB 2.2.2
Reply #30 - Jun 7th, 2008 at 7:53am
Print Post  
Hi Jet Li

Unfortunately I am still on YaBB v2.2.0 as I won't have the time to update for a year or so. However I managed to get Spell Checker working on my site and it was working ok for a few weeks but I have obviously made a change at some point that has stopped the spell check from working properly. It looks as if it is working but doesn't detect the spelling errors.. It says 'No spelling errors found"

All the code is still in place as I can successfully uninstall it through BoardMod and the check_modules.pl works successfully. All files in correct folders and chmod 755

Any ideas of where I can look for the problem?

Thanks
  
Back to top
 
IP Logged
 
ccarr
Ex Member


Re: Spell Checker V1.1a for YaBB 2.2.2
Reply #31 - Jun 17th, 2008 at 10:07pm
Print Post  
Jet Li:

All I am asking is if you have any idea where I can look for the problem and if yes... where?
  
Back to top
 
IP Logged
 
neo08
New Member
*
Offline


There is no spoon

Posts: 4
Location: Central Arkansas USA
Joined: Jun 24th, 2008
Gender: Male
Re: Spell Checker V1.1a for YaBB 2.2.2
Reply #32 - Jun 24th, 2008 at 6:56pm
Print Post  
I'm on 2.2.1 and have the same issue, No Errors Found. Did you ever get it working?  ???
  
Back to top
 
IP Logged
 
ccarr
Ex Member


Re: Spell Checker V1.1a for YaBB 2.2.2
Reply #33 - Jun 24th, 2008 at 9:11pm
Print Post  
No, sorry I didn't.
  
Back to top
 
IP Logged
 
neo08
New Member
*
Offline


There is no spoon

Posts: 4
Location: Central Arkansas USA
Joined: Jun 24th, 2008
Gender: Male
Re: Spell Checker V1.1a for YaBB 2.2.2
Reply #34 - Jun 24th, 2008 at 9:54pm
Print Post  
ccarr:

Sorry to hear that. Did you install the Mod manually like I did? And what browser do you use? I'm using IE7. maybe it's something in the java code. I'm going to start looking in that direction.

I'll post the answer IF I figure it out...

Jet Li:

Do you have the time to look at this problem for us?

Thanks in advance for any help you can give...
  
Back to top
 
IP Logged
 
mick
Senior Member
****
Offline


I love YaBB

Posts: 345
Location: Dorsten
Joined: Nov 29th, 2005
Gender: Male
Re: Spell Checker V1.1a for YaBB 2.2.2
Reply #35 - Jun 24th, 2008 at 10:03pm
Print Post  
Hi,

@people that doesn't get it ever work:

Did You read the following in first post?

Quote:
Perl Module Requirement
- Crypt::SSLeay
- Bundle::LWP


Server Check
If you consider to use our 'SpellChecker' please test first if your server have all required prerequisites installed:
Upload the check_modules.pl script included in the Mod-zip-file into the folder /cgi-bin/yabb2 (chmod 755) and call it with your browser (http://www.yourserver.xy/yabb2/check_modules.pl). The output will tell you if all needed modules are installed or what you have to do first.
If everything is ok, you can delete check_modules.pl and apply our fabulous 'SpellChecker' mod.
  
Back to top
WWW  
IP Logged
 
ccarr
Ex Member


Re: Spell Checker V1.1a for YaBB 2.2.2
Reply #36 - Jun 24th, 2008 at 10:07pm
Print Post  
It was working then it stopped but I don't know when.

I had installed another mod after this mod which made a change to the Post.pl file. I have just temporarily un-installed that mod to see if it was that but the problem remains.

I use FireFox....

@mick

In my case the 'check_modules.pl' worked before I installed it and still works. Guess its a change with googiespell.


  
Back to top
 
IP Logged
 
neo08
New Member
*
Offline


There is no spoon

Posts: 4
Location: Central Arkansas USA
Joined: Jun 24th, 2008
Gender: Male
Re: Spell Checker V1.1a for YaBB 2.2.2
Reply #37 - Jun 24th, 2008 at 11:53pm
Print Post  
The check_modules.pl said the modules are installed on my host too, although they were different than what was listed in the first post. See below:

Quote:
This script checks if all needed Perl modules for the SpellChecker-YaBB2-Mod are installed:


LWP::UserAgent -> Installed

HTTP::Request::Common -> Installed

Crypt::SSLeay -> Installed
  
Back to top
 
IP Logged
 
neo08
New Member
*
Offline


There is no spoon

Posts: 4
Location: Central Arkansas USA
Joined: Jun 24th, 2008
Gender: Male
Re: Spell Checker V1.1a for YaBB 2.2.2
Reply #38 - Jun 25th, 2008 at 3:35pm
Print Post  
OK I’m guessing here but….

It looks like this mod relies on a hack of google’s tool bar API. It simulates a web post to https://www.google.com/tbproxy/spell? then processes the returned information. I think Google changed their requirements so that this link now returns no information. Of course I could me wrong…
  
Back to top
 
IP Logged
 
Jeff
God Member
*****
Offline


There are no bugs there
are only features

Posts: 2552
Joined: Jan 14th, 2005
Gender: Male
Re: Spell Checker V1.1a for YaBB 2.2.2
Reply #39 - Jul 13th, 2008 at 12:11pm
Print Post  
Works with upcomming YaBB 2.2.3 No Update Needed.
  

greetings
Jeff
Back to top
WWW  
IP Logged
 
Acura2g
New Member
*
Offline


I love YaBB 1G - SP1.2!

Posts: 5
Joined: Jul 26th, 2007
Re: Spell Checker V1.1a for YaBB 2.2.2
Reply #40 - Aug 11th, 2008 at 11:26pm
Print Post  
I just downloaded it and installed it on 2.2.3 and it doesn't work.

The program works fine, but doesn't find miss spelled words.
  
Back to top
 
IP Logged
 
BUBF
New Member
*
Offline



Posts: 3
Joined: Jul 8th, 2008
Re: Spell Checker V1.1a for YaBB 2.2.2
Reply #41 - Aug 17th, 2008 at 1:59am
Print Post  
I have installed as per your instructions on 2.2.3 and it does not appear .

I have checked the enable spell checker box.

I have Chmod'ed the files to 755.

Do you have any ideas what could be going wrong?

I have had another look and I am getting an error "GoogieSpell" is undefined.

This is for both Post and PM.
« Last Edit: Aug 18th, 2008 at 7:37am by BUBF »  
Back to top
 
IP Logged
 
soullink
New Member
*
Offline


My Head Hurts!

Posts: 10
Location: Norwich, Norfolk, UK
Joined: Oct 2nd, 2006
Gender: Male
Re: Spell Checker V1.1a for YaBB 2.2.2
Reply #42 - Aug 29th, 2008 at 6:38pm
Print Post  
Tried running check_modules.pl and all I got was a server 500 error.
I then tried installing and running it anyway but alas no luck.
I am using www.oneandone.co.uk to host my webspace and I quite often get server 500 errors - I wonder if that has anything to do with it?
  
Back to top
WWW  
IP Logged
 
Page Index Toggle Pages: 1 2 [3] 
Send TopicPrint