Page Index Toggle Pages: [1] 2  Send TopicPrint
Hot Topic (More than 10 Replies) Anti-Leech Mod V 1.0 for YaBB 2.2 (Read 7123 times)
spyderweb
New Member
*
Offline


visit www.spyderweb.n
l

Posts: 39
Joined: Apr 22nd, 2006
Anti-Leech Mod V 1.0 for YaBB 2.2
Nov 11th, 2007 at 9:27pm
Print Post  
The Anti-Leech Mod allows you to protect your bandwidth by preventing unauthorized sites linking to your images or downloadable files in your Attachments directory of your Forum.

This Mod is only for YaBB 2.2, use Anti-Leech v1.4 for YaBB 2.0 and YaBB 2.1 boards.

If you used Anti-Leech v1.4 and upgraded to YaBB 2.2, then you need this Mod.
  

Anti-Leech_for_YaBB2.2_v1.0.zip ( 16 KB | Downloads )
Back to top
WWW  
IP Logged
 
Jeff
God Member
*****
Offline


There are no bugs there
are only features

Posts: 2552
Joined: Jan 14th, 2005
Gender: Male
Re: Anti-Leech Mod V 1.0 for YaBB 2.2
Reply #1 - Nov 11th, 2007 at 9:29pm
Print Post  
Nah you should post it in beta board first.  Tongue
  

greetings
Jeff
Back to top
WWW  
IP Logged
 
Administrator
Forum Administrator
*****
Offline


Yummm

Posts: 7
Location: Modders Rile
Joined: Oct 7th, 2014
Gender: Male
Re: Anti-Leech Mod V 1.0 for YaBB 2.2
Reply #2 - Nov 11th, 2007 at 9:56pm
Print Post  
But good job nevertheless Smiley
  

The Administrator.
Back to top
WWW  
IP Logged
 
spyderweb
New Member
*
Offline


visit www.spyderweb.n
l

Posts: 39
Joined: Apr 22nd, 2006
Re: Anti-Leech Mod V 1.0 for YaBB 2.2
Reply #3 - Nov 11th, 2007 at 10:00pm
Print Post  
Sorry
  
Back to top
WWW  
IP Logged
 
gman
Junior Member
**
Offline


The Mod Mangler <HeLp_mE>

Posts: 79
Location: Altered States
Joined: Aug 24th, 2007
Gender: Male
Re: Anti-Leech Mod V 1.0 for YaBB 2.2
Reply #4 - Dec 11th, 2007 at 12:22am
Print Post  
The mod installed okay and I uploaded and chmod'ed properly and re checked.

When I upload/attach the file does get installed into the correct attachments directory....

However the pic does not get displayed in the post?  I get a box with a red x and if you right click that box it shows the following address under properties?

http://www.heart-of-the-philippines.com/cgi-bin/yabb2/Admin/AntiLeech.pl?file=bt...
  

Unfortunately, prior to my birth, Missouri had not outlawed inbreeding.
Back to top
WWWYIM  
IP Logged
 
spyderweb
New Member
*
Offline


visit www.spyderweb.n
l

Posts: 39
Joined: Apr 22nd, 2006
Re: Anti-Leech Mod V 1.0 for YaBB 2.2
Reply #5 - Dec 13th, 2007 at 9:36pm
Print Post  
Is there a .htaccess file in your Admin directory?
If there is, delete the file.
  
Back to top
WWW  
IP Logged
 
gman
Junior Member
**
Offline


The Mod Mangler <HeLp_mE>

Posts: 79
Location: Altered States
Joined: Aug 24th, 2007
Gender: Male
Re: Anti-Leech Mod V 1.0 for YaBB 2.2
Reply #6 - Dec 14th, 2007 at 1:28am
Print Post  
spyderweb wrote on Dec 13th, 2007 at 9:36pm:
Is there a .htaccess file in your Admin directory?
If there is, delete the file.


Nope there isn't.  Tongue There is only .htaccess file in my root directory.  8)  Nothing like that in the admin directory.  Lips Sealed

Below is a pic of what is displayed in the post after the attachment is uploaded.   Shocked



Below is a pic of the properties of that red x missing pic which shows the weird address of the pic.  Also the pic is properly being uploaded into the attachments directory  :freak:

  

Unfortunately, prior to my birth, Missouri had not outlawed inbreeding.
Back to top
WWWYIM  
IP Logged
 
spyderweb
New Member
*
Offline


visit www.spyderweb.n
l

Posts: 39
Joined: Apr 22nd, 2006
Re: Anti-Leech Mod V 1.0 for YaBB 2.2
Reply #7 - Dec 14th, 2007 at 7:54pm
Print Post  
I found the problem, I made a mistake in the Anti-Leech mod.  Shocked

You have to chmod AntiLeech.pl to 755.
I wil fix the mod.
  
Back to top
WWW  
IP Logged
 
gman
Junior Member
**
Offline


The Mod Mangler <HeLp_mE>

Posts: 79
Location: Altered States
Joined: Aug 24th, 2007
Gender: Male
Re: Anti-Leech Mod V 1.0 for YaBB 2.2
Reply #8 - Dec 14th, 2007 at 11:05pm
Print Post  
spyderweb wrote on Dec 14th, 2007 at 7:54pm:
I found the problem, I made a mistake in the Anti-Leech mod.  Shocked

You have to chmod AntiLeech.pl to 755.
I wil fix the mod.


Bro, I know your mod said to chmod AntiLeech.pl to 700 but i already had it set at 755.

Both of my sites have AntiLeech.pl chmodd'ed to 755 and both my sites have the same issus that i posted above.

Thank you for trying to help me get this working!
  

Unfortunately, prior to my birth, Missouri had not outlawed inbreeding.
Back to top
WWWYIM  
IP Logged
 
spyderweb
New Member
*
Offline


visit www.spyderweb.n
l

Posts: 39
Joined: Apr 22nd, 2006
Re: Anti-Leech Mod V 1.0 for YaBB 2.2
Reply #9 - Dec 15th, 2007 at 1:07pm
Print Post  
Check your log file on your server.
I got a "Internal Server Error" when I try to execute
AntiLeech.pl on your server.
When I execute AntiLeech.pl on mine server, it asks me of I want to save the file.

Perhaps you have to delete the first line: #!/usr/bin/perl

  
Back to top
WWW  
IP Logged
 
gman
Junior Member
**
Offline


The Mod Mangler <HeLp_mE>

Posts: 79
Location: Altered States
Joined: Aug 24th, 2007
Gender: Male
Re: Anti-Leech Mod V 1.0 for YaBB 2.2
Reply #10 - Dec 15th, 2007 at 3:57pm
Print Post  
http://www.heart-of-the-philippines.com/cgi-bin/yabb2/Admin/AntiLeech.pl

I'm not sure but when I access the AntiLeech.pl it asks me if i want to save it and i did save it to my desktop with no problems?

Now I did check my server error log like you suggested and this is the error I found in connection with my issue...

"Premature end of script headers: /home/gman1964/public_html/heart-of-the-philippines/cgi-bin/yabb2/Admin/AntiLeec
h.pl"

The code line you put in the antileechPL is the correct path to my perl but just for grins I tried with and without the perl bin line and neither way worked..

Again thank you for all your help I know it eats up time you don't have and I appreciate it....

EDIT :      I got it working!  I don't know what I did wrong or how I fixed it?  Cheesy  Definately some sort of user error and no problem with the mod Wink Cheesy  end EDIT  Lips Sealed

FINAL EDIT Lips Sealed  I had to fix my OTHER 2.2 site and I figured out how I fixed it and wanted to share.  Cheesy

In the AntiLeech.pl if it is saved like this then I have the problem we discussed earlier....

Code
Select All
#!/usr/bin/perl

###############################################################################
# AntiLeech.pl
############################################################################### 



However.....  If I do the code like the example below then everything works just fine

Code
Select All
#!/usr/bin/perl
###############################################################################
# AntiLeech.pl
############################################################################### 



For some reason having a space between those two lines caused the problem and also caused my server to report "premature end of script headers".  Take away that line space and bam everything works great. 

Chow. 

P.S.  (if someone can explain to me why this line space makes a difference I am all ears Cheesy )
« Last Edit: Dec 15th, 2007 at 5:22pm by gman »  

Unfortunately, prior to my birth, Missouri had not outlawed inbreeding.
Back to top
WWWYIM  
IP Logged
 
spyderweb
New Member
*
Offline


visit www.spyderweb.n
l

Posts: 39
Joined: Apr 22nd, 2006
Re: Anti-Leech Mod V 1.0 for YaBB 2.2
Reply #11 - Dec 15th, 2007 at 8:22pm
Print Post  
The space shouldn't be the problem.
Perhaps you didn't upload it as ASCII.

I'm glad it is working now.  Smiley
  
Back to top
WWW  
IP Logged
 
cool
New Member
*
Offline


I love YaBB 1G - SP1.2!

Posts: 1
Joined: Apr 8th, 2007
Re: Anti-Leech Mod V 1.0 for YaBB 2.2
Reply #12 - Mar 7th, 2008 at 10:06pm
Print Post  
Hi, thank you for nice mod! I just installed 2.2, everything is work very well and can really protect the leecher.
However, I got the message in [Admin page]> Detailed Version Check > "Error: Untrapped Error : Can't locate ../Variables/AntiLeechcfg.txt at ./Admin/AntiLeech.pl line 45. Compilation failed in require at ./Admin/Admin.pl line 1696."

This error is not effect to Mod, the Mod process still working fine.

And one more question, once I use this Mod, why i feel that the picture is loaded everytime when I open or change the page. Not like normal picture that once the picture is loaded, it will keep in Catch and then sometime no need load the picture again.

Sorry if this question is sound stupid, but i dont know how the mod coding work. Thanks
  
Back to top
 
IP Logged
 
spyderweb
New Member
*
Offline


visit www.spyderweb.n
l

Posts: 39
Joined: Apr 22nd, 2006
Re: Anti-Leech Mod V 1.0 for YaBB 2.2
Reply #13 - Mar 21st, 2008 at 9:13pm
Print Post  
You must copy "AntiLeechcfg.txt" to the map Variables in your Forum and chmod it to 644.
  
Back to top
WWW  
IP Logged
 
Outumuro
God Member
*****
Offline


Publisher - YaBB Toolbar

Posts: 569
Location: Los Angeles
Joined: Apr 14th, 2004
Gender: Male
Re: Anti-Leech Mod V 1.0 for YaBB 2.2
Reply #14 - Mar 23rd, 2008 at 2:17pm
Print Post  
Any word on Y2.2.1 compatibility?  Anyone have a chance to test it yet?
  


Back to top
WWW  
IP Logged
 
Page Index Toggle Pages: [1] 2 
Send TopicPrint