Page Index Toggle Pages: 1 [2]  Send TopicPrint
Hot Topic (More than 10 Replies) UBBC In Maintanance Mode Message (Read 4308 times)
Jeff
God Member
*****
Offline


There are no bugs there
are only features

Posts: 2552
Joined: Jan 14th, 2005
Gender: Male
Re: UBBC In Maintanance Mode Message
Reply #15 - Nov 19th, 2005 at 4:35pm
Print Post  
H
working too  Grin
  

greetings
Jeff
Back to top
WWW  
IP Logged
 
Outumuro
God Member
*****
Offline


Publisher - YaBB Toolbar

Posts: 569
Location: Los Angeles
Joined: Apr 14th, 2004
Gender: Male
Re: UBBC In Maintanance Mode Message
Reply #16 - Nov 20th, 2005 at 6:56am
Print Post  
Thanks again! Smiley
  


Back to top
WWW  
IP Logged
 
Xavier
Senior Member
****
Offline



Posts: 442
Location: Ipswich
Joined: Apr 5th, 2005
Gender: Male
Re: UBBC In Maintanance Mode Message
Reply #17 - Jan 11th, 2006 at 11:32pm
Print Post  
Just wondering if it is possible to allow the dereferer action otherwise you cant use links in the message as the maintanance mode message appears again when u click the link
  
Back to top
WWWYIM  
IP Logged
 
Kong
God Member
*****
Offline


Is it just me or is my
back hairy???

Posts: 858
Joined: Aug 2nd, 2002
Gender: Male
Re: UBBC In Maintanance Mode Message
Reply #18 - Jan 12th, 2006 at 8:21am
Print Post  
Quote:
Just wondering if it is possible to allow the dereferer action otherwise you cant use links in the message as the maintanance mode message appears again when u click the link

Can you give me more information into what it is you mean and what you're asking for?
  


Back to top
 
IP Logged
 
Xavier
Senior Member
****
Offline



Posts: 442
Location: Ipswich
Joined: Apr 5th, 2005
Gender: Male
Re: UBBC In Maintanance Mode Message
Reply #19 - Jan 12th, 2006 at 11:06pm
Print Post  
when i add a link to the Maintanance Mode Message it displays properly but when i click it i get a redirection to the Maintanance Mode Screen Again. You can see what i mena by going to http://forum.vibecity.net/ and click the Main Page link
  
Back to top
WWWYIM  
IP Logged
 
Kong
God Member
*****
Offline


Is it just me or is my
back hairy???

Posts: 858
Joined: Aug 2nd, 2002
Gender: Male
Re: UBBC In Maintanance Mode Message
Reply #20 - Jan 12th, 2006 at 11:45pm
Print Post  
Quote:
when i add a link to the Maintanance Mode Message it displays properly but when i click it i get a redirection to the Maintanance Mode Screen Again. You can see what i mena by going to http://forum.vibecity.net/ and click the Main Page link

Oh okay I see what you're talkign about now.  Problem is the forums are in maintenance mode and not letting anything in the forums be used.  Reasoning for this is that, in theory, you'd be putting the forums into this state if you are doign maitenance, modifying, or upgrading the forums.  While doing anyone one of these 3 things that action or the file whcih containts it may be unavailable.

So I never really put any thought into this being a problem.  Why not just use a standard url and not use dereferer?
  


Back to top
 
IP Logged
 
Xavier
Senior Member
****
Offline



Posts: 442
Location: Ipswich
Joined: Apr 5th, 2005
Gender: Male
Re: UBBC In Maintanance Mode Message
Reply #21 - Jan 13th, 2006 at 12:31am
Print Post  
I have i used
Code
Select All
[url]http://vibecity.net[/url] 

It automatically adds the dereferer
  
Back to top
WWWYIM  
IP Logged
 
Kong
God Member
*****
Offline


Is it just me or is my
back hairy???

Posts: 858
Joined: Aug 2nd, 2002
Gender: Male
Re: UBBC In Maintanance Mode Message
Reply #22 - Jan 13th, 2006 at 12:49am
Print Post  
Quote:
I have i used
Code
Select All
[url]http://vibecity.net[/url] 

It automatically adds the dereferer

Oh ya I see that now.  Hmm.... Okay well either thats new, or I never saw it added, or I just didn't think of it at the time. Tongue

I'll take a look at it in a bit and come up with something later.  Just have to give me a bit of time.  I'm very busy lately.
  


Back to top
 
IP Logged
 
Kong
God Member
*****
Offline


Is it just me or is my
back hairy???

Posts: 858
Joined: Aug 2nd, 2002
Gender: Male
Re: UBBC In Maintanance Mode Message
Reply #23 - Jan 13th, 2006 at 6:18am
Print Post  
Alright, try this and tell me if it works.  It should be working, although I'm having a slight problem testing it on my end, not sure why.

Code
Select All
<edit file>
YaBB.pl
</edit file>

<search for>

		if (!$iamadmin) { require "$sourcedir/Maintenance.pl"; &InMaintenance; }
</search for>

<add before>
		if ($action eq 'dereferer') {
			&Dereferer;
		}
</add before>

 



Edit - I tested it a bit more with other URLs and it works.  For some reason I can't get it to go to www.3dxl.com and this make absolutely no sense to me because www.3dxl.co.uk works and it's the same site on teh same server. Tongue.
  


Back to top
 
IP Logged
 
ThM
God Member
*****
Offline



Posts: 585
Location: Germany, Nds.
Joined: May 21st, 2006
Gender: Male
Re: UBBC In Maintanance Mode Message
Reply #24 - Jul 1st, 2008 at 9:42am
Print Post  
It's working too with 2.2.2. Add the following code into the modfile. These modification allow, that guest can see here Multimedia File and Clickable Links. Thanks Jet Li, the old fox   Grin

Code
Select All
<edit file>
Sources/Maintenance.pl
</edit files> 



Code
Select All
<search for>
if ($action eq 'detailedversion') { return 1; }
</search for> 



Code
Select All
<add after>
undef $guest_media_disallowed;
</add after> 


  

Greeting ThM
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1 [2] 
Send TopicPrint