Page Index Toggle Pages: [1] 2  Send TopicPrint
Very Hot Topic (More than 25 Replies) MemberMap 3.0 for SP 1.3.1 - 1.4 (Read 7098 times)
Carsten
God Member
*****
Offline


...to much YaMS

Posts: 3281
Location: Langå
Joined: Aug 2nd, 2002
Gender: Male
MemberMap 3.0 for SP 1.3.1 - 1.4
Jul 18th, 2004 at 4:39pm
Print Post  
MemberMap 3.0 for SP 1.3.1 - 1.4

new since ver. 2.7:
I've rewritten a lot of the code and re-designed the main map view and the setup area. The maps have been moved to their own folder and the "managing" of maps and flags has been made easier (hopefully).

This mod adds a map-function to YaBB for members to "pin" their location on a map.

Features:

Everybody can (guests only if allowed by Admin):
-view location of members on the main-map
-click on a members pin to view the members profile
-click on a name in the name list in main-map to make the members pin flash
-view members map in members "View Profile"

Members and Adnim can:
-select map, type location, select State/Region* and Country
-point and click on a map to place a pin where they live
-edit their location at any time from "View Profile"
-remove pin from map

Admin can:
-admin can make location required on registration from Admin-Center
-add own maps
-change the name, number and order of maps
-add/delete countries and flags
-add/delete states/regions
-allow/disallow guest access to member map
-allow/disallow state/region selection
-sort the main-map name list by country or name
-view hide index-headers in name list
-allow/disallow gender-colored pins from Admin-Center
-If gender-color disallowed, admin can choose red, green or blue pin color
-set view/hide location in posts as flag, text or both from Admin-Center

*if enabled by Admin.


Included in the zip file:

-MemberMap.pl
-MemberMap_3_sp131_14.mod
-MemberMap_3_amm_sp131_14.mod (Add More Membergroups compatible)
-state.txt (120 states/regions/territories in USA, Canada, Australia, Germany, Austria and Switzerland)
-9 maps in .gif format
-204 flags in .gif format
« Last Edit: Aug 27th, 2006 at 4:33pm by Carsten »  

membermap_3_sp131_14.zip ( 239 KB | Downloads )

If you knock your head against a brick wall and hear a hollow sound, it's not necessarily coming from the wall.
Back to top
 
IP Logged
 
paclady
Full Member
***
Offline


I love YaBB 1G - SP1.3!

Posts: 196
Joined: Feb 6th, 2004
Re: MemberMap 3.0 for SP 1.3.1
Reply #1 - Jul 30th, 2004 at 11:25am
Print Post  
Hello Carsten,

May I ask, can you just install this over the exisiting Map or do you have to remove the old version and then re-install this one?

Thank you.
  
Back to top
WWW  
IP Logged
 
Frank Rizzo
New Member
*
Offline


I love YaBB 1G - SP1.2!

Posts: 11
Location: Scotland
Joined: Jul 22nd, 2004
Gender: Male
Re: MemberMap 3.0 for SP 1.3.1
Reply #2 - Jul 30th, 2004 at 2:23pm
Print Post  
Hi Carsten.

I've installed the Member Map 3.0 and think it's totally ace. However, I cant use the option in my settings to make people use it on Registration. If I do select this option, new would-be members get an error instead of the Registration page. I have a thread here which gives a better explanation:

http://www.boardmod.org/yabb/YaBB.pl?board=troubleshooting;action=display;num=10...


Kindest Regards.

Frank Rizzo.
  
Back to top
YIMAIM  
IP Logged
 
ruahighlander
Guest


Re: MemberMap 3.0 for SP 1.3.1
Reply #3 - Aug 3rd, 2004 at 3:39pm
Print Post  
I installed this the other day, but when I try to get to the map or setup the map, it says "can't access directory ./YabbImages/maps". WTF I can access the pics, but I cant open a standalone directory to list the pics.
  
Back to top
 
IP Logged
 
Frank Rizzo
New Member
*
Offline


I love YaBB 1G - SP1.2!

Posts: 11
Location: Scotland
Joined: Jul 22nd, 2004
Gender: Male
Re: MemberMap 3.0 for SP 1.3.1
Reply #4 - Aug 5th, 2004 at 2:50pm
Print Post  
Hey there ruahighlander.

I'm a highlander by the way.  Grin

In your post it said that the pathway to your maps directory was ./YaBBImages/maps. Is this exaclty what the error says?

I'm no expert on this but I've been having a good look in my Preferences and Settings and have noticed that Absolute Paths to things contained in the /cgi-bin/yabb have paths such as ./Sources, ./Variables etc. However, Absolute Paths to the YaBBImages are ../..YaBBImages. Therefore, ensure that your Absolute Paths to both your maps and flags directories are:

../../YaBBImages/maps
and
../../YaBBImages/flags

Ignore this post if you already have this. Just thought I'd point out my observations here.


Frank Rizzo.
  
Back to top
YIMAIM  
IP Logged
 
Ruahighlander
Guest


Re: MemberMap 3.0 for SP 1.3.1
Reply #5 - Aug 9th, 2004 at 5:13pm
Print Post  
I was thinking the same thing, but when I try to go into the prefs. and setting I get the same message "Can't open directory (./YaBBImages/maps)!". So how can I change the directory without going into prefs. and settings? I have tried the Settings.pl, but didnt see it, tried membermap.pl, but it refers to the dir. as mapdir or something like that, no actual "dir.".

P.S. Are you an RU Highlander or an "I want me lucky charms" highlander?
  
Back to top
 
IP Logged
 
Frank Rizzo
New Member
*
Offline


I love YaBB 1G - SP1.2!

Posts: 11
Location: Scotland
Joined: Jul 22nd, 2004
Gender: Male
Re: MemberMap 3.0 for SP 1.3.1
Reply #6 - Aug 13th, 2004 at 1:04am
Print Post  
Quote:
I was thinking the same thing, but when I try to go into the prefs. and setting I get the same message "Can't open directory (./YaBBImages/maps)!". So how can I change the directory without going into prefs. and settings? I have tried the Settings.pl, but didnt see it, tried membermap.pl, but it refers to the dir. as mapdir or something like that, no actual "dir.".


Hi again Ruahighlander.

Let me get this straight. Are you saying you get this Can't open directory (./YaBBImages/maps)! error message when you click on your Preferences and Setting link in the Admin Center? Surely this can't be so?

As for your your Settings.pl file. Look in it for a bit like this:
Code
Select All
# Note: directories other than $imagesdir do not have to be changed unless you move things



$boarddir = ".";	 # The server path to the board's folder (usually can be left as '.')

$boardsdir = "./Boards";     # Directory with board data files

$datadir = "./Messages";	# Directory with messages

$memberdir = "./Members";	# Directory with member files

$sourcedir = "./Sources";	# Directory with YaBB source files

$vardir = "./Variables";     # Directory with variable files

$facesdir = "../../YaBBImages/avatars";     # The server path to your avatars (userpics) folder

$facesurl = "http://www.mysite.com/YaBBImages/avatars";    # URL to your avatars folder

$imagesdir = "http://www.mysite.com/YaBBImages";   # URL to your images folder

$ubbcjspath = "http://www.mysite.com/ubbc.js";   # URL to your 'ubbc.js' (REQUIRED for post/modify to work properly)

$faderpath = "http://www.mysite.com/fader.js";   # URL to your 'fader.js'

$helpfile = "http://www.mysite.com/YaBBHelp/index.html";   # URL to your help file

$mapsdir = '../../YaBBImages/maps';   # Absolute path to the MemberMap maps

$flagdir = '../../YaBBImages/flag';   # Absolute path to the MemberMap flags 



In most cases, the $(foldername)dir needs to be present alongside the $(foldername)dir URL. However, as you can see from mine, the URL isn't required for the Maps and Flags directories. However, the Absolute Paths are. Check to see what differences your Settings.pl has compared to mine (apart from the mysite.com parts of course).

Also ensure that if your Forum is on a Unix server that your directory names in this file (e.g. '../../YaBBIMages/flags') etc. match the exact case of the directories uploaded to your server. This has to be so due to Unix servers being case-sensitive. 


Frank Rizzo.
  
Back to top
YIMAIM  
IP Logged
 
paclady
Full Member
***
Offline


I love YaBB 1G - SP1.3!

Posts: 196
Joined: Feb 6th, 2004
Re: MemberMap 3.0 for SP 1.3.1
Reply #7 - Aug 16th, 2004 at 9:40am
Print Post  
May I ask, can you just install this over the exisiting Map or do you have to remove the old version and then re-install this one?

Thank you
  
Back to top
WWW  
IP Logged
 
Frank Rizzo
New Member
*
Offline


I love YaBB 1G - SP1.2!

Posts: 11
Location: Scotland
Joined: Jul 22nd, 2004
Gender: Male
Re: MemberMap 3.0 for SP 1.3.1
Reply #8 - Aug 16th, 2004 at 8:24pm
Print Post  
Hi Paclady.

I would suggest you remove the old one first otherwise  the mod wouldn't be able to find the lines to modify in your files.

Also, when you get this installed, could you post back in this thread and let me know if you are able to use the option which makes it mandatory for newley-registering members to add their details to the Member Map? I ask because everyone else seems to have forsaken this thread.   Cry Cry Cry


Frank Rizzo.
  
Back to top
YIMAIM  
IP Logged
 
Hi-TEK
Guest


Re: MemberMap 3.0 for SP 1.3.1
Reply #9 - Sep 14th, 2004 at 8:14pm
Print Post  
Greetings,

I have recently installed this mod and can make changes via the Admin center with no problems. The problem I have is after my forum memebrs place their pins on the respected maps when you visit their individual profiles the map image is completely missing. I can see the pin graphic but the country map shows up as a blank images. It is almost like it is not saving the changes to their profile. I can see all the maps when I hit the Members Map link from the top forum menu which is why this has me puzzled. I hope this makes sense and  that someone can provide some help.
  
Back to top
 
IP Logged
 
Hi-TEK
Guest


Re: MemberMap 3.0 for SP 1.3.1
Reply #10 - Sep 16th, 2004 at 8:52pm
Print Post  
The search for fixing this bug continues and I have e-mailed Carsten with no response. I spent the day manually looking over the MembersMap mod file and making sure that the changes to the following were correct:

english.lng
Sources/Admin.pl
Sources/AdminEdit.pl
Sources/Display.pl
Sources/Profile.pl
Sources/Register.pl
Sources/Subs.pl
Sources/SubList.pl

I even made sure that Settings.pl is pointing to the correct virual directories for flag and maps. Everything works except for maps displaying on the individual user profiles. When I check the source of the missing image I get the following:

http://www.sitename.com/YaBBImages/maps/.gif

instead of the Map image. Does anyone know how to fix this?
  
Back to top
 
IP Logged
 
Carsten
God Member
*****
Offline


...to much YaMS

Posts: 3281
Location: Langå
Joined: Aug 2nd, 2002
Gender: Male
Re: MemberMap 3.0 for SP 1.3.1
Reply #11 - Sep 17th, 2004 at 12:42am
Print Post  
Sorry guys - havn't been here for quite a while - been busy elsewhere (YaBB 2)  Smiley

Seems there is a bug in the 'non-amm' version of MemberMap 3.0 - fixed now in the zip package to download in first post.

If you already installed MemberMap 3.0 try this:

In Profile.pl find:

Code
Select All
if($membcontinent eq "") {
	fopen(FILE, "$vardir/continent.txt");
	@continent = <FILE>;
	fclose(FILE);
	foreach (@continent) { $_ =~ s~[\n\r]~~g; }
	$memcontinent = $continent[0];
}
else {
	foreach $cname (@continent){
		if(lc $cname eq lc $membcontinent) { $memcontinent = $cname; }
	}
} 



and replace it with:

Code
Select All
fopen(FILE, "$vardir/continent.txt");
@continent = <FILE>;
fclose(FILE);
foreach (@continent) { $_ =~ s~[\n\r]~~g; }
if($membcontinent eq "") {
	$memcontinent = $continent[0];
}
else {
	foreach $cname (@continent){
		if(lc $cname eq lc $membcontinent) { $memcontinent = $cname; }
	}
} 

  

If you knock your head against a brick wall and hear a hollow sound, it's not necessarily coming from the wall.
Back to top
 
IP Logged
 
Carsten
God Member
*****
Offline


...to much YaMS

Posts: 3281
Location: Langå
Joined: Aug 2nd, 2002
Gender: Male
Re: MemberMap 3.0 for SP 1.3.1
Reply #12 - Sep 17th, 2004 at 1:02am
Print Post  
Frank Rizzo wrote on Jul 30th, 2004 at 2:23pm:
Hi Carsten.

I've installed the Member Map 3.0 and think it's totally ace. However, I cant use the option in my settings to make people use it on Registration. If I do select this option, new would-be members get an error instead of the Registration page. I have a thread here which gives a better explanation:

http://www.boardmod.org/yabb/YaBB.pl?board=troubleshooting;action=display;num=10...


Kindest Regards.

Frank Rizzo.

Looks to me like you installed MemberMap by hand - true?  Wink

In your modded Register.pl find:

Code
Select All
if($req_location) {
	fopen(FILE, "$vardir/country.txt"); 



and add:
Code
Select All
~;
} 


before it.
  

If you knock your head against a brick wall and hear a hollow sound, it's not necessarily coming from the wall.
Back to top
 
IP Logged
 
Hi-TEK
Guest


Re: MemberMap 3.0 for SP 1.3.1
Reply #13 - Sep 18th, 2004 at 9:08pm
Print Post  
Thanks Carsten,

The change you recommended for Profile.pl worked perfectly and the maps are finally showing up on the individual user profiles. I am greatful!
  
Back to top
 
IP Logged
 
Keith
New Member
*
Offline



Posts: 28
Joined: Sep 17th, 2004
Gender: Male
Re: MemberMap 3.0 for SP 1.3.1
Reply #14 - Sep 19th, 2004 at 1:56am
Print Post  
I have MemberMap 3.0 working fine on 1.3.2, however, when I view a profile, it doesn't show the map.  It shows maps everywhere else, just not when viewing a profile.

I get the standard IE red cross.  If I look at the properties of this in IE to see what it's trying to load, it is looking for:

my domain/yabb/images/maps/.gif
  
Back to top
 
IP Logged
 
Page Index Toggle Pages: [1] 2 
Send TopicPrint