Page Index Toggle Pages: 1 Send TopicPrint
Hot Topic (More than 10 Replies) problems with installation (Read 5207 times)
k_girl
New Member
*
Offline


I love YaBB 1G - SP1!

Posts: 9
Joined: Sep 12th, 2002
problems with installation
Sep 14th, 2002 at 5:39am
Print Post  
Hello,

I am having problems simply starting BoardMod on my machine.  i am running on a linux machine.

I have downloaded it.  I start it up and immediately get an error message (that is not in english).  I read in the FAQ that you might get an error message if BoardMod is unable to find the code which needs to be changed.  It also says that usually that happens with the wrong version has been selected.  (worng mod version?)  The BoardMod version I'm running was for linux...so I'm sort of confused about how to fix this.  When I start it up there is nothing listed in the dropdown menu. 

Please help me. I'm kind of at a loss at the moment  Undecided and would appreciate help...  Thank you.
  
Back to top
 
IP Logged
 
Tea-Master
Forum Administrator
*****
Offline



Posts: 1945
Location: north germany
Joined: Oct 21st, 2001
Gender: Male
Re: problems with installation
Reply #1 - Sep 14th, 2002 at 6:12am
Print Post  
k_girl wrote on Sep 14th, 2002 at 5:39am:
Hello,
I start it up and immediately get an error message (that is not in english).  

seems to be an unnormal message cause all "normal" ones (f.ex. when folders does not exists etc) are in english. seems to be one "general" boardmod for linux problem.
can u post the exact german message here, plz?
what linux on which machine do u run?


Quote:
I read in the FAQ that you might get an error message if BoardMod is unable to find the code which needs to be changed.  It also says that usually that happens with the wrong version has been selected.  (worng mod version?)

this error u only get if u directly try to install a mod by clicking the checkbox next to the mod name.
with "wrong version" is meant the wrong mod version to the wrong YaBB version.


Quote:
When I start it up there is nothing listed in the dropdown menu.

so it continues starting after showing the error message?


  
Back to top
WWW  
IP Logged
 
k_girl
New Member
*
Offline


I love YaBB 1G - SP1!

Posts: 9
Joined: Sep 12th, 2002
Re: problems with installation
Reply #2 - Sep 14th, 2002 at 9:10am
Print Post  
The message says

Zugriffsverletzung bei Adresse 40334625 beim auf adrese 0000018

I am running an obscure version of linux.  I'm running on an SGI with a Linux for SGI.  I think it's kernel is 7.2 though.   

When the dialog box comes up during startup, I click OK and it continues starting up.  However, when the GUI comes up everything is blank.  (Is that what is supposed to be like?)  If I click on any of the checkboxes to the right (labeled mod1, mod2, mod3) I get another dialog box saying that "Error code 8  The following mod file could not be found path /home/wherever/Mods/mod2"
  
Back to top
 
IP Logged
 
Christer Alexander
God Member
*****
Offline


Make my day...

Posts: 3443
Location: Lethbridge
Joined: Feb 10th, 2002
Gender: Male
Re: problems with installation
Reply #3 - Sep 14th, 2002 at 9:47am
Print Post  
I think it's a compile error, or an error in the program core. Because BM was written in german Delphi, all non-programmer made messages is in german
  

Code
Select All
unless(0) { stab("LoonyPandora"); next; } 

Back to top
IP Logged
 
k_girl
New Member
*
Offline


I love YaBB 1G - SP1!

Posts: 9
Joined: Sep 12th, 2002
Re: problems with installation
Reply #4 - Sep 14th, 2002 at 9:56am
Print Post  
compile error?  All I did for the install is I put it in my home directory and changed some permissions to make some things executable.

The reason I'm doing all of this is because I want to make it so that the passowrds are not in clear text for yabb. 

If I cannot make this program run, is there any other way that I could do that?

I'm realizing as I read the INSTALL page that it has not been tested on my version of 7.2 linux, which is not RedHat. 

Hmm....  any suggestions?  If it's an error in the program core, I guess that means that it just doesn't work with my linux.  Any help would be appreciated.  thanks.
  
Back to top
 
IP Logged
 
Administrator
Forum Administrator
*****
Offline


Yummm

Posts: 7
Location: Modders Rile
Joined: Oct 7th, 2014
Gender: Male
Re: problems with installation
Reply #5 - Sep 14th, 2002 at 2:16pm
Print Post  
Quote:
Zugriffsverletzung bei Adresse 40334625 beim auf adrese 0000018
This error normally occures when the wrong librarys are used. BoardMod uses a special version of Qt (made by Borland). It differes from the normally used Qt libs. For that reason, BoardMod comes with a lib folder including the required libs. However I don't suggest to copy them to  /usr/lib, instead run BoardMod with the script which comes with the package: boardmod-run. That will set some enviroment variables to use the correct libs
  

The Administrator.
Back to top
WWW  
IP Logged
 
k_girl
New Member
*
Offline


I love YaBB 1G - SP1!

Posts: 9
Joined: Sep 12th, 2002
Re: problems with installation
Reply #6 - Sep 17th, 2002 at 6:21pm
Print Post  
I run the program boardmod-run from both the absolute and relative paths to execute it.  I have the boardmod program in my home directory (and not in the same directory as the form (could that be the problem?)

I am not sure what the QT libraries are.  Or, how to change my environment varaibles to use the correct QT libraries. 

I have done what you suggested:  running boardmod-run from the command line and I still get the same error...in german. 

Hmm......do you have any other suggestions?  I would appreciate it because I really want to get this to work.  Thank you.
  
Back to top
 
IP Logged
 
Christer Alexander
God Member
*****
Offline


Make my day...

Posts: 3443
Location: Lethbridge
Joined: Feb 10th, 2002
Gender: Male
Re: problems with installation
Reply #7 - Sep 18th, 2002 at 5:38am
Print Post  
k_girl wrote on Sep 17th, 2002 at 6:21pm:
I am not sure what the QT libraries are.  Or, how to change my environment varaibles to use the correct QT libraries. 

That's what BoardMod does.

QT libraries are a special type of libraries required by Borland Delphi programs, I belive.
  

Code
Select All
unless(0) { stab("LoonyPandora"); next; } 

Back to top
IP Logged
 
k_girl
New Member
*
Offline


I love YaBB 1G - SP1!

Posts: 9
Joined: Sep 12th, 2002
Re: problems with installation
Reply #8 - Sep 18th, 2002 at 11:08pm
Print Post  
Hmm.....  ok.  so BoardMod changes the environment variables to use the correct QT Borland libraries? And these libraries come with the BoardMod program.  So....how come when I start boardmod from the command line using the boardmod-run program I get the error message in german?  I'm not sure what to do at this point.  I'm at the command line on my linux machine and I type "./boardmod-run" and I get this error.  Any suggestions on what I can do to fix this?  Please please please let me know.  I'm very confused at this point about what I'm doing wrong.   Sad
  
Back to top
 
IP Logged
 
k_girl
New Member
*
Offline


I love YaBB 1G - SP1!

Posts: 9
Joined: Sep 12th, 2002
Re: problems with installation
Reply #9 - Sep 26th, 2002 at 11:41pm
Print Post  

I downloaded the boardmod251beta.tar.gz file because it was the only tarred  file on the download page and it was the only file intended to work on linux.

Are any of the other downloads workable for linux? 

Perhaps I can just change to something other than the beta and that will fix the problem..   Undecided

Please let me know what download you would recommend for a linux machine. 

  
Back to top
 
IP Logged
 
Administrator
Forum Administrator
*****
Offline


Yummm

Posts: 7
Location: Modders Rile
Joined: Oct 7th, 2014
Gender: Male
Re: problems with installation
Reply #10 - Sep 27th, 2002 at 8:23am
Print Post  
k_girl wrote on Sep 17th, 2002 at 6:21pm:
I have the boardmod program in my home directory (and not in the same directory as the form (could that be the problem?)

What do you mean by that?

The beta3 tar.gz is the only linux version of boardmod.

A completely different thing you can try is to run the windows version in Wine (winehq.com).
  

The Administrator.
Back to top
WWW  
IP Logged
 
k_girl
New Member
*
Offline


I love YaBB 1G - SP1!

Posts: 9
Joined: Sep 12th, 2002
Re: problems with installation
Reply #11 - Sep 27th, 2002 at 11:30pm
Print Post  

If I have access to a windows machine, can I install boardmod on that machine.  Install the necessary module on a copy of yabb there and then move everything over to my linux machine. 

will that work?
  
Back to top
 
IP Logged
 
Administrator
Forum Administrator
*****
Offline


Yummm

Posts: 7
Location: Modders Rile
Joined: Oct 7th, 2014
Gender: Male
Re: problems with installation
Reply #12 - Sep 28th, 2002 at 8:05am
Print Post  
yes that should work too.
  

The Administrator.
Back to top
WWW  
IP Logged
 
k_girl
New Member
*
Offline


I love YaBB 1G - SP1!

Posts: 9
Joined: Sep 12th, 2002
Re: problems with installation
Reply #13 - Sep 30th, 2002 at 6:40pm
Print Post  
THANK YOU THANK YOU THANK YOU!!!

I tried installing it on a windows platform and it worked without any problem  (Woo Hoo!!)

However, I am trying to find a module that will encrypt the passwords.  I tried the security module but that doesn't seem to do anything to encrypting the passwords.

Which module would I install that would encrypt the passwords so that they will not be stored in plaintext on my web server?  Please let me know.  Thanks!!!!
  
Back to top
 
IP Logged
 
Administrator
Forum Administrator
*****
Offline


Yummm

Posts: 7
Location: Modders Rile
Joined: Oct 7th, 2014
Gender: Male
Re: problems with installation
Reply #14 - Sep 30th, 2002 at 6:48pm
Print Post  
the Password Security mod encripts users passwords when they sign-up.
  

The Administrator.
Back to top
WWW  
IP Logged
 
Page Index Toggle Pages: 1
Send TopicPrint